Follow

Need Winclone 3.7

If you purchased Winclone 4 but need Winclone 3 to use on your Mac running 10.6.8 or earlier, we can send you a link to download Winclone 3! 

Email us directly at support@twocanoes.com 

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk